0
Not a bug

Reporting Bugs

ReturnOfALegend 2 years ago • updated by SHOAIB (Moderator (EN)) 1 year ago 3

I've been experiencing two bugs. 1. While I'm playing in different maps, at random intervals, my tank self-destructs! Usually when self-destruction takes place is by pressing Delete and a 5 second cooldown starts, but my tank self-destructed without any cooldown and I did not press the Delete button Once I self destructed twice in a row, I did not even spawn and i self destructed. Please fix this bug because I lost 1st position in battles because of self-destruction. 2. I've been using the mine module for quick sometime, but at some occasions, some tanks seem to just move over my mine without blowing up! this happened 2-3 times and it is becoming really annoying for me, I hope you will find a solution to these 2 bugs, and Thanks for you time!

Answer

Answer
Not a bug

This is due to lag, It causes anti-cheat false positive.

Both these seem to be an internet issue, some I have experienced before. Sometimes your mine appears much later on the server. Also when you lag you could trigger the anti cheat therefore be self destructed. 

Do you ever see other other/all players lagging in a battle? (Teleports, shifts, out of control)

Both the problems are known and are caused by "Lag" check your internet because


 :- As you lag the upload speed (the speed with which you can send information to other devices) of your computer decreases and causes the delay in the transfer of information(the information that reports to the server that you have placed a mine) and this might cause that the tank pursuing you might not blow up but after the server gets the report , the mine would act normally...  


:-  If you lag frequently like teleporting from place to place and if your tank accelerates on it's own or the turret keeps spinning this means you are lagging and when the server detects irregular movements of your tank it triggers the Anti-Cheat-System thinking that you are a hacker teleporting on the map.. 


Please provide a screenshot of your Internet Speed

Test it here:  Google SpeedtestSpeedtest

Answer
Not a bug

This is due to lag, It causes anti-cheat false positive.