+7
Fixed

Mac OS X client keeps crashing

OzCo 10 months ago • updated 4 months ago 39

Today, I keep getting the error screen that says "an error has occurred" with option to report, restart or quit.


No matter how many times I restart or quit and restart client it still crashes.  I have restarted computer, done everything it still crashes!

Answer

Answer

Good News
Tanki X is back on Mac OS.

Fire At Will!

me too. deleted prefs - restarted.  "An unexpected error has occurred" - Report | Restart | Quit

Are you using Mac OS X? or windows?  They are going to want our log files, but I can not see where that files is under Mac OS X.  Do you know?

+2

OSX - you can find logs in Applications | Utilities | Console - use the search box top left in console.


Just a note - This is as of this morning GMT+1 - tankix was running great yesterday evening. - this is NOT a new install issue.


another weird thing - my logs seem to show tankix trying to  parse audio plugins!!


20/07/2018 10:23:09.962 tankix[658]: 10:23:09.961 WARNING:  >compload> 472: Regressif.component -- file:///Library/Audio/Plug-Ins/Components/: trouble parsing Info.plist's AudioComponents, key (null); entry: <CFBasicHash 0x106e53c10 [0x7fff7439e440]>{type = mutable dict, count = 7,
entries =>
2 : <CFString 0x7fff74328b60 [0x7fff7439e440]>{contents = "manufacturer"} = inrD
7 : <CFString 0x7fff7432c620 [0x7fff7439e440]>{contents = "factoryFunction"} = <CFString 0x106e54d80 [0x7fff7439e440]>{contents = "RegressifAUFactory"}
8 : subtype = inRq
9 : description = LoFi
10 : type = <CFString 0x106e55460 [0x7fff7439e440]>{contents = "kAudioUnitType_MusicEffect"}
11 : name = <CFString 0x106e54de0 [0x7fff7439e440]>{contents = "Inear_Display: Regressif"}
12 : version = <CFNumber 0x1000037 [0x7fff7439e440]>{value = +65536, type = kCFNumberSInt64Type}
}


The tankix.com app download was updated 19-07-2018 09:57 - I'm testing that - it already has a new downloading x mb/225mb gauge in the top right.


The last app I downloaded was dated 2nd July


I'll let you know if it works for me.

I just deleted and redownloaded app.  Made no difference, still crashes.  Seems in the last 24 hours others have the same problem.

yep - same here - new download didn't help - it's a shame. I'm guessing they don't test things before serving them up for general failure. It's not like we can 'roll back'.

+1

20/07/2018 12:06:33.000 kernel[0]: process tankix[442] thread 4705 caught burning CPU!; EXC_RESOURCE supressed due to audio playback
20/07/2018 12:19:41.000 kernel[0]: process tankix[529] thread 11880 caught burning CPU!; EXC_RESOURCE supressed due to audio playback

+1

When is this gonna work?

+1

the last time a new download was enought, but before sownloading it again, I read some comments here that say that did not work. i don't know why the 'report' button does not send the log to the developer automatically. i don´t know what kind of log they require so using console as user 'pootle' recomends i get this



.tanki log

hope this can be fixed soon.

+1

Same for me, I redownload game very 15 days, was working as of 01:00 UTC this morning, now it doesn't work. please fix, I need to teleport on 2 accounts

I don't how to grab logs tho

+1

Mac Os ,Im the same was running perfectly 18hrs ago . I even reinstalled after a full cleanup and now  it just keeps crashing . Please fix devs 

+1

Same bruh. I already delete the app everytime an update happens because it always fails to work after an update. But this time, after re-installing the app, it just jumps into a "an unexpected error occured" every time.

+2

Me too mate. Simply can't start. Was all good yesterday morning but no longer payable since last night.

I am a new player and was reallly eager to play the game, but it just crashed, I guess I'll just delete it in a week or two!

+1

Still down. Never had a problem like in the year and a half I've been playing on mac

+2

Waited a day but problem still there. Somebody need to fix this please.


+2

I've tried over the past two days restarting the program, but it always gets stuck at the error screen. I've looked for the game files to delete, and mysteriously they don't appear. I do a reinstall, and after downloading and updating, same error screen. I look for the game files, they don't appear anywhere. I can't send any game logs or remove problem files if they don't even appear.


The game ran perfectly fine before, and when I did have a problem about 2 weeks ago, a reinstall was all that it took. It's not like my Mac can't run the game.

+2

ya me too. Everyone here use mac are experiencing the same problem,. They shouldn't deploy a new update before weekend. Now I guess they are on holiday so they couldn't fix it now. Wait for few more days and see what happen.

+1

I do have same problem with issue "An unexpected error has occurred" - Report | Restart | Quit   what we can do??

+3
Started

Hi there, guys! 

The issue is known and our developers are currently working on fixing it. 

Apologies for any inconvenience this might have caused.

still down, I don't expect it to be fixed till Monday, but at least it will be Monday in Russia very soon, and if they couldn't figure out what was wrong on friday, I don't expect it to be a 2 minute fix.I just hope they get it done before Thursday, when TO will probably begin preparations for the War

+2

GOOD NEWS! - My last failed new install has updated itself this morning with two shortish updates - everything appears to be ok as far as running the game without crashing.


I don't have time to play yet but this looks like a problem solved.


Thank you Artcore (et al).

One small bug -not mission critical - (it was there before) - is that the client crashes during an automatic restart - for example - when changing graphics settings or when logging out of account.

+2
Fixed

Yes, the problem with the Max OS client was fixed. I will forward the issue you mentioned. Thank you!

yes is fixed for me as well, thx all

It started working since the day before yesterday, I am so happy. I really like the game!

+2

Is this happening again - it was working just fine 8-10 hours ago - this morning it downloaded a big chunk of data and then stopped on the unexpected error screen .


I'm on OSX so I thought I'd check other OSX people.

+3

Yes, OSX is crashing again.  Can Tanki X please test these updates on Mac OSX before releasing to make sure it does not keep crashing like this!!

+3

same thing happened again today, made a clean install and the message "an error has occurred" is all I get....so the OSX problem definitely not fixed!!!...any idea or a chance to play TX again?

+2

Last time this happened on a Friday and it wasn't looked at till Monday, let us see how long before they notice this buy, respond and fix it.  Thankfully, it is Monday.

Guys, please create new topics for new issues. You can write all you want here, nobody is going to notice or check it. 

+1

But it turns out the same issue happen again now :(

+2

This problem comes back again after today's update.  


bad script, bad deploy....bad bad  bad....

+1

We are investigating it. 

Because it happened many times in a row, we are looking into the reason the Max version is built with so many exceptions and errors. 

Hopefully will have it fixed and the number of such incidents will drop. 

Ty for reporting.

Answer

Good News
Tanki X is back on Mac OS.

Fire At Will!

+1

Thank you!

Please dont update for a while, we want to play